Articles of android support library

Aggiungi la libreria di supporto di Android v4 a intellij ide

Sto cercando di utilizzare viewpager dalla libreria di supporto Android v4 in intelli j. Attualmente, sto usando l’SDK Android 4.1 Ho copiato android-support-v4.jar nel mio progetto android intellij sotto ‘libs’ nelle impostazioni del progetto di intellij Sono andato su “Modules” => “MyModuleName” => scheda dipendenze , e aggiungo android-support-v4.jar, navigando il percorso alla cartella libs […]

enum vs android @Intdef – quale è meglio ottimizzato

So che quando si confrontano le costanti con le costanti di enumerazione si prende meno spazio e si può essere primitivi. Sto facendo ricerche sull’annotazione @Intdef su Android e qualcuno può dirmi se la sua memoria migliore usa @Intdef contro un enum. È consigliabile ora in Android mettere da parte enum e utilizzare @intdef andando […]

Installa il pacchetto: “Libreria di supporto Android”

Sto codificando un’applicazione Xamarin e questi sono gli errori che ottengo durante la creazione della mia applicazione: C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA5206: Please install package: ‘Android Support Library’ available in SDK installer. Android resource directory C:\Users\Simon\Documents\Xamarin\SimpleOnePageViewPager\SimpleOnePageViewPager\Components\googleplayservicesgingerbread-16.0.0.1\lib\android\19.1.0\content\support/v7/appcompat doesn’t exist. (XA5206) (SimpleOnePageViewPager) C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA5207: Please install package: ‘Android Support Library’ available in SDK installer. […]

Eccezione irreversibile: java.lang.NoClassDefFoundError: android.support.v7.app.AppCompatDelegateImplV23

Nella mia ultima versione alcuni dei miei utenti (meno dello 0,2%) stanno subendo un arresto anomalo perché non è ansible trovare android.support.v7.app.AppCompatDelegateImplV23 . Non riesco a riprodurre il problema, ricevo solo segnalazioni su crashlytics. Ho usato apktool per estrarre i file dal mio apk e posso vedere AppCompatDelegateImplV23.smali lì. Qualche idea su cosa potrebbe accadere? […]

‘Imansible caricare RSSupport: findLibrary ha restituito null’ quando si utilizza RenderScript on 2.3 emulator

RenderScript non funziona sull’emulatore Android 2.3. 04-04 15:37:39.146: W/dalvikvm(863): Unable to resolve superclass of Landroid/support/v8/renderscript/RenderScript$2; (316) 04-04 15:37:39.146: W/dalvikvm(863): Link of class ‘Landroid/support/v8/renderscript/RenderScript$2;’ failed 04-04 15:37:39.146: E/dalvikvm(863): Could not find class ‘android.support.v8.renderscript.RenderScript$2’, referenced from method android.support.v8.renderscript.RenderScript.setErrorHandler 04-04 15:37:39.146: W/dalvikvm(863): VFY: unable to resolve new-instance 890 (Landroid/support/v8/renderscript/RenderScript$2;) in Landroid/support/v8/renderscript/RenderScript; 04-04 15:37:39.146: D/dalvikvm(863): VFY: replacing opcode 0x22 […]

CollapsingToolbarLayout con titolo multilinea

È ansible rendere il testo espanso del titolo di CollapsingToolbarLayout su più righe (simile all’attributo TextView.maxLines )?

Problema di paesaggio di fondo

Sto riscontrando un comportamento errato quando mostro una finestra di dialogo dei fogli di fondo in modalità orizzontale. Il problema si verifica nella versione 24. + della libreria di progettazione. Secondo l’immagine sottostante il foglio inferiore non viene visualizzato correttamente solo in orizzontale. Im usando la class BottomSheetDialog e sto seguendo questo tutorial: http://www.skholingua.com/blog/bottom-sheet-android , […]

Il frammento deve essere una class statica pubblica da ricreare correttamente dallo stato dell’istanza

Dopo l’aggiornamento all’ultimo repository di supporto, compile ‘com.android.support:appcompat-v7:24.2.0’ compile ‘com.android.support:design:24.2.0’ compile ‘com.android.support:percent:24.2.0’ compile ‘com.android.support:recyclerview-v7:24.2.0’ Sto ottenendo la strana eccezione. java.lang.IllegalStateException: Fragment null must be a public static class to be properly recreated from instance state. at android.support.v4.app.BackStackRecord.doAddOp(BackStackRecord.java:435) at android.support.v4.app.BackStackRecord.add(BackStackRecord.java:414) at android.support.v4.app.DialogFragment.show(DialogFragment.java:154) at com.androidapp.base.BaseActivity.showDialogFragment(BaseActivity.java:78) at com.androidapp.MainActivity.showNewDialog(MainActivity.java:304) at com.androidapp.MainActivity$6.onClick(MainActivity.java:228) Nella mia class BaseActivity , ho creato un […]

Libreria di supporto Android 23.2.0 che fa sì che la freccia della barra degli strumenti sia nera

Recentemente ho aggiornato la mia libreria di supporto Android ieri alla versione 23.2.0 e all’improvviso tutti i dispositivi pre-Lolipop hanno cambiato il colore della freccia posteriore, dell’hamburger e (menu a tre punti) in nero. Quando sono sempre bianchi. I dispositivi lecca-lecca sembrano andare bene. ecco il mio style.xml che non è stato modificato affatto tra […]

L’utilizzo di buildToolsVersion 23 non riesce perché più file dex definiscono ‘AnimRes’

Prima di richiedere DUPLICATE , leggi la domanda. Ciò si verifica solo con l’ultima versione degli strumenti di generazione. Le versioni precedenti non mostrano questo problema. Ho già provato le soluzioni offerte su altre domande qui per più definizioni di @AnimRes . Nessuno mi ha aiutato finora, motivo per cui ho pubblicato una nuova domanda. […]